taskrambler-9999.ebuild 640 Bytes
# Copyright 1999-2016 Georg Hopp
# Distributed under the terms of the GNU General Public License v3

EAPI=6

inherit eutils git-r3 autotools

DESCRIPTION="The taskrambler web server."
HOMEPAGE="https://gitlab.weird-web-workers.org/taskrambler/taskrambler"
EGIT_REPO_URI="https://gitlab.weird-web-workers.org/${PN}/${PN}.git"
EGIT_BRANCH="next"
LICENSE="GPL-3+"

SLOT="0"

KEYWORDS="~amd64 ~x86"

DEPEND="
	dev-libs/libtrbase
	dev-libs/libtrio
	dev-libs/libtrhash
	dev-libs/libtrdata"
RDEPEND="${DEPEND}"

src_prepare() {
	aclocal
	libtoolize --copy
	autoheader
	automake --gnu --add-missing --copy
	autoconf
}

src_compile() {
	emake -j1
}