armrr-9999.ebuild 660 Bytes
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=5

inherit eutils git-r3

DESCRIPTION="Create a pacman mirrorlist"
HOMEPAGE="git://github.com/Gen2ly/armrr"
EGIT_REPO_URI="git://github.com/Gen2ly/armrr"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64"
RDEPEND="
	app-shells/bash
	sys-apps/sed
	net-misc/curl"

src_compile() {
	# we have bash under /bin not under /usr/bin
	sed -i 's/\/usr\/bin\/bash/\/bin\/bash/' armrr
	sed -i 's/\/etc\/pacman.d\/mirrorlist/${DESTDIR}\/etc\/pacman.d\/mirrorlist/' armrr
}

src_install() {
	exeinto /usr/bin
	doexe armrr
	dodoc license.txt readme.md
}