taskrambler-9999.ebuild 832 Bytes
# Copyright 1999-2016 Georg Hopp
# Distributed under the terms of the GNU General Public License v3

EAPI=6

inherit eutils git-r3 autotools

DESCRIPTION="The taskrambler web server."
HOMEPAGE="https://gitlab.weird-web-workers.org/taskrambler/taskrambler"
EGIT_REPO_URI="https://gitlab.weird-web-workers.org/${PN}/${PN}.git"
EGIT_BRANCH="next"
LICENSE="GPL-3+"

SLOT="0"

KEYWORDS="~amd64 ~x86"

DEPEND="
	dev-libs/libtrbase
	dev-libs/libtrio
	dev-libs/libtrhash
	dev-libs/libtrdata"
RDEPEND="${DEPEND}"

src_prepare() {
	einfo "Regenerating autotools files..."
	eaclocal -I "${WORKDIR}/m4" || die "aclocal failed"
	libtoolize --copy || die "libtoolize failed"
	eautoheader || die "autoheader failed"
	eautomake --gnu --add-missing --copy || die "automake failed"
	eautoconf || die "autoconf failed"
}

src_compile() {
	emake -j1
}